Solucionar error con subversion: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.x86_64


cpanel-whm

Si usas CPanel con Centos 5.4 y necesitas instalar subversion probablemente te aparezca un error de dependencias al ejecutar:

# yum install subversion

Con salida:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: centosu.centos.org
 * base: centosy3-msync-dvd.centos.org
 * extras: centosu.centos.org
 * updates: centosv.centos.org
addons                                                   |  951 B     00:00     
base                                                     | 2.1 kB     00:00     
extras                                                   | 1.1 kB     00:00     
updates                                                  | 1.9 kB     00:00     
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package subversion.i386 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Processing Dependency: neon >= 0.25.5-6.el5 for package: subversion
--> Processing Dependency: libneon.so.25 for package: subversion
--> Processing Dependency: libapr-1.so.0 for package: subversion
--> Processing Dependency: libaprutil-1.so.0 for package: subversion
---> Package subversion.x86_64 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Running transaction check
---> Package apr.i386 0:1.2.7-11.el5_3.1 set to be updated
---> Package apr-util.i386 0:1.2.7-7.el5_3.2 set to be updated
--> Processing Dependency: libpq.so.4 for package: apr-util
---> Package neon.i386 0:0.25.5-10.el5_4.1 set to be updated
---> Package neon.x86_64 0:0.25.5-10.el5_4.1 set to be updated
---> Package subversion.i386 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Running transaction check
---> Package postgresql-libs.i386 0:8.1.18-2.el5_4.1 set to be updated
---> Package subversion.i386 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.4.2-4.el5_3.1 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Finished Dependency Resolution
subversion-1.4.2-4.el5_3.1.x86_64 from base has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.x86_64 (base)
subversion-1.4.2-4.el5_3.1.i386 from base has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386 (base)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386 (base)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.x86_64 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Y si pruebas a instalar el paquete de perl desde los repositorios, te dirá que esta actualizado:

# yum install perl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: centosu.centos.org
 * base: centosy3-msync-dvd.centos.org
 * extras: centosu.centos.org
 * updates: centosb2.centos.org
Excluding Packages in global exclude list
Finished
Setting up Install Process
Nothing to do

No te preocupes, tiene fácil solución. Bajaremos los paquetes de la versión 1.35 y lo instalaremos solventando el error:

# wget http://yum.trixbox.org/centos/5/RPMS/perl-URI-1.35-3.noarch.rpm

Instalamos el paquete de Perl usando el comando:

# rpm -i perl-URI-1.35-3.noarch.rpm

Ahora, prueba a instalar subversion y ya no tendrás el problema anterior:

# yum install subversion

1 pensamiento en “Solucionar error con subversion: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.x86_64”

  1. Pingback: Instalar Django en un servidor Centos 5.4 | Shakaran

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.