Instalar Transmission 1.31 en Ubuntu (Repositorios Bortis)


Acerca de transmission
Acerca de Transmission, versión 1.31

Transmission es un cliente de Bittorrent rápido y sencillo incluido en Ubuntu por defecto. Personalmente me gusta mucho, pero la versión incluida en Ubuntu Hardy 8.04 está bastante desfasada, ya que es la versión 1.06. Aunque si tenemos los repositorios hardy-backports activados podemos tener la 1.22.

Ayer leía un articulo en MundoGeek de que salía la versión 1.31, pero me desilusioné al ver que en los repositorios de ubuntu no se encontraba y que en la página web oficial de descargas de Transmission no se encontraba disponible para descargar el archivo .deb correspondiente, ni en los repositorios. únicamente podías descargarte las fuentes y compilarlas.

Aunque esto no es difícil, si es más tedioso y personalmente me gusta menos, asi que me queje en los foros de Transmission y muy amablemente me dijeron que no es responsabilidad de los desarrolladores de Transmission mantener los paquetes actualizados para las distribuciones. Me indigné un poco, pero también me pusieron un enlace al anuncio oficial en el foro, donde un usuario ponía a disposición unos repositorios (no oficiales) para los .deb en Ubuntu, estos son los repositorios de Bortis.

Aunque no me parece la mejor de las soluciones (lo suyo serían los repositorios oficiales de Ubuntu), al menos conseguí mi fin (aunque llegados a este punto hubiese sido más facil compilar las fuentes).

Bien, si quieres añadir los repositorios de Bortis para tener transmission siempre actualizado a cada nueva versión, copia y pega esta linea en tu terminal.

echo "##Transmission (Bortis)" | sudo tee -a /etc/apt/sources.list; echo "deb http://ppa.launchpad.net/bortis/ubuntu hardy main" | sudo tee -a /etc/apt/sources.list;sudo apt-get update; sudo apt-get upgrade;

Esto añadirá el repositorio de Bortis (necesita privilegios de superusuario), actualizara los repositorios y los paquetes (y si, TODO en una sola línea de terminal!)

Si también estas interesado en tener los repositorios para el código fuente (destinado más a desarrolladores), puedes copiar y pegar también esta línea en el terminal:

echo "##Transmission sources (Bortis)" | sudo tee -a /etc/apt/sources.list; echo "deb-src http://ppa.launchpad.net/bortis/ubuntu hardy main" | sudo tee -a /etc/apt/sources.list;sudo apt-get update; sudo apt-get upgrade;

Si sólo quieres descargar los paquetes .deb, necesitas descargar e instalar estos dos (pincha en el nombre para descargar):

Actualización 11-08-08: Estos .deb ya están obsoletos, el 11-08-08 salio la 1.32 y es mejor que añadas los repositorios para tener la última versión, ya que en un futuro no iré añadiendo los enlaces a cada versión de .deb, no obstante, puedes encontrar todas las versiones de .deb para descargar en:
http://ppa.launchpad.net/bortis/ubuntu/pool/main/t/transmission/

transmission-common_1.31

transmission-gtk

Como último, decir que también me encargue de sugerir la idea para que actualizaran los repositorios en Ubuntu para Transmission en la web de Brainstorm, pero me dijeron que mejor lo reportara como bug en Launchpad, donde ya lo han anotado para Intrepid, así que posiblemente la versión de Transmission sea de las más actualizadas.


Nota: para los posibles comentarios sobre que existen versiones en servicios como GetDeb, la versión mayor es la 1.22 (mientras escribo), por eso recurrí a buscar otras alternativas.


7 pensamientos en “Instalar Transmission 1.31 en Ubuntu (Repositorios Bortis)”

  1. saludos, instale los 2 paquetes, pero me da un error de dependencias, libatk1.0-0, ejecute un sudo apt-get install libatk1.0-0 y me dijo que ya lo tengo en su version mas reciente, si me podeis ayudar

  2. En principio se me ocurren dos posibles soluciones para arreglarlo:

    1) El paquete tiene de nombre libatk1.0-0 pero eso no indica su versión, realmente lleva otra versión y solo es el nombre.

    Viendo eso puedes ver que la última versión para hardy es la libatk1.0-0 (1.22.0-0ubuntu1) en esta dirección:
    http://packages.ubuntu.com/hardy/libatk1.0-0

    Si bajando e instalando ese paquete sigue dándote error de dependencias, puedes probar a instalar el paquete de más actual de intrepid libatk1.0-0 (1.23.5-0ubuntu1) desde esta dirección:
    http://packages.ubuntu.com/intrepid/libatk1.0-0

    2) Si todo esto no da resultado, la otra solución que puede que funcione es que habilites los repositorios de hardy-backports (en Administración>Orígenes de Software) y vuelvas a actualizar.

    Esto te actualizara muchos paquetes y dependencias nuevas en muchos paquetes y puede solucionar el problema.

    Todo esto, estoy asumiendo que usas Ubuntu 8.04, porque probablemente si usas una versión más antigua de Ubuntu el problema puede ser ese y deberías actualizar tu versión.

    Espero tu respuesta tanto como si sea tu problema solucionado o no y ¡Gracias por comentar!.

    Saludos

  3. Lo siento si te ha molestado, no era mi intención. Mi intención era la de informar y apoyar tu entrada con más información. Si aun así no te agrada, eres libre de borrarlo.

    Saludos.

  4. Thanks for mentioning my work. There are updated packages for 1.32 in the repository and I am very happy that the Ubuntu Team has importet Transmission 1.32 to the upcoming Intrepid Ibex release. Sorry for writing in «broken english» but my spanish is even worse 🙂

  5. Your work was impressive. That would solve a lot and I wanted to contribute to add in the Ubuntu repositories. This is the true spirit of Ubuntu community.

    Keeping in this way Ubuntu and will become very good OS.

    Do not worry about language (I think you’re Swiss), the important thing is to communicate, do not care any language.

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.