Desinstalar controladores propietarios de ATI en Ubuntu

24 09 2012
ATI? Piensatelo dos veces

ATI? Piensatelo dos veces

El soporte de ATI en GNU/Linux que ofrece deja mucho que desear en los controladores oficiales y propietarios. Son frecuentes los fallos en aplicaciones que hacen un uso normal de la tarjeta gráfica y con las ultimas incorporaciones de Compiz y Unity al escritorio de Ubuntu, la aceleración es muy lenta para un uso regular. A fecha de hoy, los controladores libres de MESA, en su última versión (9.0), tampoco ofrecen muchas de las funcionalidades básicas o incluso no disponen del soporte de OpenGL 2.1 (lanzado en 2006) en la mayoría de las tarjetas gráficas.

No hablemos de OpenGL 3.0 o superior a menos que dispongas de tarjeta gráfica Intel o Nvidia (con controladores propietarios también). Aunque MESA tiene bastante actividad, prácticamente cada día hay nuevo código desarrollado, tiene un desarrallo demasiado lento para adaptarse rápido al mercado del escritorio o incluso de juegos (aunque parece que pueden existir avances en los próximos meses).

Resumiendo aunque puede que inicialmente te haya ido bien con los controladores propietarios de ATI, quizás tengas mejor soporte al usar los controladores libres y te ofrezcan algo más de estabilidad y funcionalidades. Por otro lado, usando los controladores libres es más posible que tus fallos se corrijan pronto, ya que se lanzan versiones más rapidamente en cada nueva versión de Ubuntu que las que ofrece ATI. También estarías favoreciendo la alternativa que esta basada en software libre.

Por ello, para desinstalar los controladores propietarios de ATI, ejecuta los siguientes comandos:

1
2
3
4
sudo apt-get purge xorg-driver-fglrx fglrx-*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
sudo dpkg-reconfigure xserver-xorg
sudo apt-get install --reinstall xserver-xorg-core

Después reinicia tu ordenador y ya estarás usando los controladores libres. Puedes comprobarlo con el comando:

1
glxinfo | grep Mesa
VN:F [1.9.22_1171]
Rating: 8.0/10 (4 votes cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)


Solucionar error libccs: dlopen de Compiz en Ubuntu

12 03 2009
Compiz logo

Logo de Compiz

Si al ejecutar Compiz te aparece el siguiente error en la consola:

?Descargar error.txt
1
libccs: dlopen: /usr/lib/compizconfig/backends/libgconf.so: cannot open shared object file: No such file or directory

Es posible que se deba a que no tienes el paquete instalado del decorador de ventanas para gnome de Compiz. Basta con que instales el paquete compizconfig-backend-gconf:

1
sudo apt-get install compizconfig-backend-gconf

Con esto la librería que se necesita quedara instalada y no se mostrara dicho error.

Nota: Si usas KDE el paquete necesario es compizconfig-backend-kconf (es cambiar la G de Gnome por la K de KDE)

También he reportado un bug en Launchpad para que este error sea algo más informativo, con suerte no tendrás que recurrir de nuevo a este articulo ;)

VN:F [1.9.22_1171]
Rating: 7.0/10 (1 vote cast)
VN:F [1.9.22_1171]
Rating: 0 (from 0 votes)





Cargado con 272 consultas en 1,117 segundos